Home » RDBMS Server » Enterprise Manager » OMS crashes
icon5.gif  OMS crashes [message #158258] Thu, 09 February 2006 08:17
mhignett
Messages: 1
Registered: February 2006
Location: London
Junior Member
I'm having trouble starting oms. It looks like Java is crashing in some internet related API, so my first thought was that the server was not configured correctly as we'd just updated our DNS servers. I checked

$ hostname
RHLINUX01.<company name>.com


and
$ dnsdomainname
<company name>.com


This looks correct to me. Is it? Would dnsdomainname normally return just the bit following RHLINUX01? The Oracle install is 9.2.0.5 (but OEMCTL say 9.2.0.1.0 - is this correct?) on Redhat Enterprise Server 2.1. The output I get is the following:

$ oemctl start oms
OEMCTL for Linux: Version 9.2.0.1.0 Production
Copyright (c) 1998, 2002, Oracle Corporation.  All rights reserved.
Starting the Oracle Management Server...SIGSEGV   11*  segmentation violation
        stackbase=BFFEC108, stackpointer=BFFEB054

Full thread dump:
    "SIGQUIT handler" (TID:0x421e02a0, sys_thread_t:0x823be78, state:R, thread_t
: t@16387, sp:0x0 threadID:0xce8, stack_base:0xbf5ffa80, stack_size:0x200000) pr
io=41
    "Finalizer thread" (TID:0x421e0088, sys_thread_t:0x823bd50, state:CW, thread
_t: t@8194, sp:0x0 threadID:0xce7, stack_base:0xbf7ffa80, stack_size:0x200000) p
rio=41
    "main" (TID:0x421e00b0, sys_thread_t:0x8228048, state:R, thread_t: t@8192, s
p:0x0 threadID:0xcd1, stack_base:0xbffec108, stack_size:0x200000) prio=41 *curre
nt thread*
        java.net.InetAddress.<clinit>(InetAddress.java)
        com.visigenic.vbroker.orb.ORB.getLocalHost(ORB.java:409)
        com.visigenic.vbroker.orb.ORB.set_parameters(ORB.java:906)
        org.omg.CORBA.ORB.init(ORB.java:103)
        oracle.sysman.emSDK.common.corba.InitORBHelper.initORB(InitORBHelper.jav
a:81)
        oracle.sysman.emSDK.common.corba.InitORBHelper.initORB(InitORBHelper.jav
a:104)
        oracle.sysman.vxx.vxxo.VxxoORB.<init>(VxxoORB.java:179)
        oracle.sysman.vxx.vxxo.VxxoORB.<init>(VxxoORB.java:165)
        oracle.sysman.vxx.vxxo.VxxoORB.<init>(VxxoORB.java:155)
        oracle.sysman.vxx.vxxo.VxxoORB.<init>(VxxoORB.java:171)
        oracle.sysman.vxx.vxxo.VxxoEMORB.<init>(VxxoEMORB.java:197)
        oracle.sysman.vxa.VxaOMSPing.ping(VxaOMSPing.java:272)
        oracle.sysman.vxa.VxaOMSPing.main(VxaOMSPing.java:191)
Monitor Cache Dump:
Registered Monitor Dump:
    Thread queue lock: <unowned>
    Name and type hash table lock: <unowned>
    String intern lock: <unowned>
    JNI pinning lock: <unowned>
    JNI global reference lock: <unowned>
    BinClass lock: <unowned>
    Class loading lock: <unowned>
    Java stack lock: <unowned>
    Code rewrite lock: <unowned>
    Heap lock: <unowned>
    Has finalization queue lock: <unowned>
    Finalize me queue lock: <unowned>
        Waiting to be notified:
            "Finalizer thread" (0x823bd50)
    Monitor registry: owner "main" (0x8228048, 1 entry)
Aborted


Any ideas what I'm doing wrong? I'm running this as the oracle user not root. Should I start oms as root? Or some other user? The database nodes themselves are up and running.

Thanks,

Martin Hignett
Previous Topic: OEM status is wrong
Next Topic: OEM in Oracle10G does not start (URGENT)
Goto Forum:
  


Current Time: Sun Nov 28 02:31:09 CST 2021